読者です 読者をやめる 読者になる 読者になる

おもしろwebサービス開発日記

Ruby や Rails を中心に、web技術について書いています

ActionController::MethodNotAllowed

新しくviewを作ってアクセスしたらこんなエラー。

ActionController::MethodNotAllowed

あとこんなような事も書いてあった。でも普通にブラウザからアクセスしただけなので getでアクセスしてるはず。おかしい。

Only get and post requests are allowed.

調べたら、Rails2.1.0のときにmongrelのバージョンが古い(1.1.5未満)だと起こる現象なよう。なのでこれで解決。

sudo gem update mongrel